•  

    Click HERE to join our forum and participate in the discussions.

     

Acceleration Anomolies


ajmike

New member
Joined
Nov 20, 2016
Messages
3
Reaction score
0
Points
1
Vehicle Year
1985
Vehicle
Bronco 2
Engine Size
2.8L
Suspension Style
4wd
1985 B2 2.8L new reman engine, carb, clutch and more. Upon accelerating in first gear the rate of acceleration slows down around 20 mph then the acceleration rate speeds up at 24 mph. Accelerating in 2nd gear the acceleration slows down around 30 mph then the acceleration rate speeds up at around 44 mph. accelerating in 3rd gear it the rate of acceleration slows down around 50 mph, then speeds up around 64 mph. This happens ALL THE TIME! I keep my foor on the accelerator at the same position. In all gears basically the engine accelerates but then accelerates at a slower speed then speeds up. does anyone have any ideas as to what is causing this? Otherwise the engine runs good. As far as I know this didn't happen before the engine swap.
 


ajmike

New member
Joined
Nov 20, 2016
Messages
3
Reaction score
0
Points
1
Vehicle Year
1985
Vehicle
Bronco 2
Engine Size
2.8L
Suspension Style
4wd
sorry i put this in the wrong category. I tried to delete it but don't know how. sorry.
 

LeBronCo

Member
Joined
Jan 10, 2021
Messages
40
Reaction score
2
Points
8
Location
North County San Diego
Vehicle Year
1987 and 1986
Vehicle
Ford Bronco II
Suspension Style
4wd
My credo
Life is more fun if you own a Ford Bronco II
1985 B2 2.8L new reman engine, carb, clutch and more. Upon accelerating in first gear the rate of acceleration slows down around 20 mph then the acceleration rate speeds up at 24 mph. Accelerating in 2nd gear the acceleration slows down around 30 mph then the acceleration rate speeds up at around 44 mph. accelerating in 3rd gear it the rate of acceleration slows down around 50 mph, then speeds up around 64 mph. This happens ALL THE TIME! I keep my foor on the accelerator at the same position. In all gears basically the engine accelerates but then accelerates at a slower speed then speeds up. does anyone have any ideas as to what is causing this? Otherwise the engine runs good. As far as I know this didn't happen before the engine swap.
It sounds like midrange jetting is inadequate hence the lack of performance at the intervals you mentioned in each gear. Low speed, good, mid speed not so, high speed good.
 

Top