•  

    Click HERE to join our forum and participate in the discussions.

     

no power under load


LeBronCo

Member
Joined
Jan 10, 2021
Messages
75
Reaction score
8
Points
8
Location
North County San Diego
Vehicle Year
1987 and 1986
Vehicle
Ford Bronco II
Suspension Style
4wd
My credo
Life is more fun if you own a Ford Bronco II
87 2.9. Checked all sensors, spark, fuel. Found rust in tank so replaced tank, sending unit, both pumps and filters. Checked injectors; ok there. Here's what is happening. It starts, idles and revs fine. Pulls away in first gear ok. Second, plus/minus ok. Third gear with a little incline and it feels like its plugged up. Will not pull. It feels like it fires unevenly almost like it's only running on 4-5 cylinders. Forget fourth gear. WTH?
 


Uncle Gump

Moderator
Forum Moderator
Joined
Mar 4, 2020
Messages
87
Reaction score
6
Points
8
Vehicle Year
2022
Vehicle
Bronco
Is this the same truck you've been working on for a couple months?

Have you checked for restricted exhaust?
 

LeBronCo

Member
Joined
Jan 10, 2021
Messages
75
Reaction score
8
Points
8
Location
North County San Diego
Vehicle Year
1987 and 1986
Vehicle
Ford Bronco II
Suspension Style
4wd
My credo
Life is more fun if you own a Ford Bronco II
Yes it is. I had to wait for parts. I initially ordered the tank, etc. from LMC. I called after 2 weeks and then I was informed the tank was on back order so I went to Rock Auto and had everything in 4 days. I was thinking a bad cat. I watched a video on YouTube where a dirty MAFS was the problem. The tricky that about this one was the MAFS was giving off a good reading. I'll check both and see if either one help.
 

Uncle Gump

Moderator
Forum Moderator
Joined
Mar 4, 2020
Messages
87
Reaction score
6
Points
8
Vehicle Year
2022
Vehicle
Bronco
Well good luck...

A plugged cat is fairly easy to diagnose... google testing for restricted exhaust with vacuum gauge.
 

Top