•  

    Click HERE to join our forum and participate in the discussions.

     

Stalling / backfire right after startup


Darel

New member
Joined
May 5, 2019
Messages
15
Reaction score
0
Points
1
Vehicle Year
1986
Vehicle
Ford Bronco II
Geez, it's been a while since I updated this, my apologies. I know everyone has been waiting with bated breath to hear any news on my issue. :)

In the end it seems like it was a combination of issues:

  1. dead battery, killed by a:
  2. bad starter, which became a real problem due to stalling from a:
  3. bad ignition module
So a while ago I went and drove the truck (cold) around the neighborhood trying to figure out what was going on. I mentioned above, the battery wasn't holding a charge at all, so I put a new one in. Drove the truck around stumbling and farting, problem consistently getting worse. Pulled in the driveway, shut it off, wouldn't start again with the new battery RRRRRRRT. OK, starter's locking up when it gets hot and probably drawing mucho amps that contributed to the demise of the battery, and the low / no charge in the system was playing with the ECU causing it to run poorly. In fact, my son (his truck) even mentioned a few times about the starter staying engaged after he let off the key, I'd assumed it was the key switch but maybe that was hanging up too. So, now that the ignition module, battery and starter have all been replaced, the truck's been running great. I honestly believe all three of those contributed and I was never going to get to the bottom of the issue without replacing all 3. Thanks for all the help!

D
 



Top